aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgney Lopes Roth Ferraz <agney@debian.org>2006-06-09 08:51:12 -0300
committerSimon Quigley <tsimonq2@ubuntu.com>2017-06-19 14:38:35 -0500
commit18820242e374421ebd6d504a20d11f310b2ac023 (patch)
tree22f0f468866e0405e11dd71b1ccedc2f7d7eb5c7
parent5463b95dd354d4aff1c626b756d5586750f24d4d (diff)
Import Debian changes 0.4-3
hardinfo (0.4-3) unstable; urgency=low * Updated project's homepage, old is unreachable. (Closes: #370797) * upated printers.h (Closes: #370363)
-rw-r--r--arch/common/printers.h26
-rw-r--r--config.h2
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rw-r--r--debian/copyright6
-rw-r--r--debian/watch11
6 files changed, 43 insertions, 11 deletions
diff --git a/arch/common/printers.h b/arch/common/printers.h
index 8632ea18..01beb5dd 100644
--- a/arch/common/printers.h
+++ b/arch/common/printers.h
@@ -19,18 +19,30 @@
void
scan_printers(void)
{
- GModule *cups;
+ static GModule *cups = NULL;
static int (*cupsGetPrinters) (char ***printers) = NULL;
static char *(*cupsGetDefault) (void) = NULL;
+ static char *libcups[] = { "libcups",
+ "libcups.so",
+ "libcups.so.1",
+ "libcups.so.2",
+ NULL };
if (printer_list)
g_free(printer_list);
if (!(cupsGetPrinters && cupsGetDefault)) {
- cups = g_module_open("libcups", G_MODULE_BIND_LAZY);
- if (!cups) {
+ int i;
+
+ for (i = 0; libcups[i] != NULL; i++) {
+ cups = g_module_open(libcups[i], G_MODULE_BIND_LAZY);
+ if (cups)
+ break;
+ }
+
+ if (!cups) {
printer_list = g_strdup("[Printers]\n"
- "CUPS libraries cannot be found=");
+ "CUPS libraries cannot be found=");
return;
}
@@ -38,7 +50,8 @@ scan_printers(void)
|| !g_module_symbol(cups, "cupsGetDefault",
(gpointer) & cupsGetDefault)) {
printer_list =
- g_strdup("[Printers]\n" "No suitable CUPS library found=");
+ g_strdup("[Printers]\n"
+ "No suitable CUPS library found=");
g_module_close(cups);
return;
}
@@ -62,6 +75,7 @@ scan_printers(void)
g_free(printers[i]);
}
} else {
- printer_list = g_strdup("[Printers]\n" "No printers found");
+ printer_list = g_strdup("[Printers]\n"
+ "No printers found");
}
}
diff --git a/config.h b/config.h
index 626701dd..64ad2c8a 100644
--- a/config.h
+++ b/config.h
@@ -6,7 +6,7 @@
#define ARCH_i386
#define PLATFORM "Linux"
#define KERNEL "2.6.16-1-686"
-#define HOSTNAME "lxadm03.intranet.dasa"
+#define HOSTNAME "comanche.linuxhome.com.br"
#define PREFIX "/usr/share/hardinfo/"
#define PREFIX_LIBS "/usr/lib/hardinfo/"
#define DEBUG 1
diff --git a/debian/changelog b/debian/changelog
index dfdcc7c8..e23b6ec0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+hardinfo (0.4-3) unstable; urgency=low
+
+ * Updated project's homepage, old is unreachable. (Closes: #370797)
+ * upated printers.h (Closes: #370363)
+
+ -- Agney Lopes Roth Ferraz <agney@debian.org> Fri, 9 Jun 2006 08:51:12 -0300
+
hardinfo (0.4-2) unstable; urgency=low
* Limited supported architectures. (Closes: #368582)
diff --git a/debian/control b/debian/control
index 3d8650dc..43f79a74 100644
--- a/debian/control
+++ b/debian/control
@@ -13,4 +13,4 @@ Description: Displays system information
hardware and operating system. Currently it knows about PCI, ISA PnP, USB,
IDE, SCSI, Serial and parallel port devices.
.
- Homepage: http://alpha.linuxmag.com.br/~leandro/hardinfo
+ Homepage: http://hardinfo.berlios.de
diff --git a/debian/copyright b/debian/copyright
index 00d5b7df..7f996d3a 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,7 +1,7 @@
-This package was debianized by Leandro Pereira <leandro@linuxmag.com.br> on
-Sun, 15 Jun 2003 11:13:14 -0300.
+This package was debianized by Agney Lopes Roth Ferraz <agney@debian.org> on
+Fri, 9 Jun 2006 08:49:25 -0300.
-It was downloaded from http://alpha.linuxmag.com.br/~leandro/hardinfo/
+It was downloaded from http://hardinfo.berlios.de/
Upstream Author: Leandro Pereira <leandro@linuxmag.com.br>
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 00000000..90379650
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,11 @@
+# Example watch control file for uscan
+# Rename this file to "watch" and then you can run the "uscan" command
+# to check for upstream updates and more.
+# See uscan(1) for format
+
+# Compulsory line, this is a version 3 file
+version=3
+
+# Uncomment to examine a Webpage
+# <Webpage URL> <string match>
+http://developer.berlios.de/project/showfiles.php?group_id=5897 hardinfo-(.*)\.tar\.gz