aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBurt P <pburt0@gmail.com>2019-07-28 15:39:34 -0500
committerLeandro A. F. Pereira <leandro@hardinfo.org>2019-07-29 19:44:59 -0700
commitb4337288f40bcc8fdadb8807647f0e0409ebf5af (patch)
treeb623e60963029d78869139dc4c674fd18ec7824d /CMakeLists.txt
parent6938cbfd0c8d64aa93633fc7423879de757fd45c (diff)
udisks2: get sdcard oem/manufacturer
udisks doesn't provide, but it can be looked up using attributes from sysfs. Signed-off-by: Burt P <pburt0@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e0749f9e..e9fff9f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -121,6 +121,7 @@ set(HARDINFO_RESOURCES
"data/benchmark.conf"
"data/benchmark.data"
"data/vendor.ids"
+ "deps/sysobj_early/data/sdcard.ids"
)
set(HARDINFO_MANPAGES
@@ -218,6 +219,7 @@ add_library(sysobj_early STATIC
deps/sysobj_early/src/gg_slist.c
deps/sysobj_early/src/strstr_word.c
deps/sysobj_early/src/auto_free.c
+ deps/sysobj_early/src/util_ids.c
deps/sysobj_early/gui/uri_handler.c
)
set_target_properties(sysobj_early PROPERTIES COMPILE_FLAGS "-std=c99 -Wall -Wextra -Wno-parentheses -Wno-unused-function")