aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLeandro Pereira <leandro@hardinfo.org>2018-03-12 09:14:01 -0700
committerLeandro Pereira <leandro@hardinfo.org>2018-03-12 09:15:42 -0700
commit1906d3027dc3ad8b9b5533712299d48e265c852c (patch)
tree00b432b3861a0407bc2117b9023084c3e0e49726 /CMakeLists.txt
parent217eb89c8f4de0e00e8b27dc8349d8295d6e68a4 (diff)
Do not use hardcoded path for icon
Use just the symbolic name "hardinfo", allowing for icon packs to provide alternative icons. Fixes #227
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ab62cad6..8038aead 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -299,3 +299,7 @@ install(FILES ${HARDINFO_MANPAGES}
DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/man/man1
PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
)
+install(FILES pixmaps/hardinfo.png
+ DESTINATION share/icons/hicolor/48x48/apps
+ PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
+)