aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBurt P <pburt0@gmail.com>2019-07-04 15:50:04 -0500
committerLeandro A. F. Pereira <leandro@hardinfo.org>2019-07-06 13:06:43 -0700
commitcf3983370bfa97a123699338b43af524619fff6e (patch)
tree176878c1b802dbd9ec124abbaa774b0085d27226 /CMakeLists.txt
parent5ca49f7fb12ce6362d78f722305e2b13bb401fde (diff)
Memory devices: enable more warnings and cleanup
Signed-off-by: Burt P <pburt0@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 103359df..f4a970e3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -203,7 +203,7 @@ set_source_files_properties(
modules/devices/dmi_memory.c
# modules/devices/spd-decode.c
PROPERTIES
- COMPILE_FLAGS "-std=c99 -Wno-deprecated-declarations"
+ COMPILE_FLAGS "-std=c99 -Wall -Wextra -Wno-unused-function -Wno-deprecated-declarations -Wno-switch"
)
foreach (_module ${HARDINFO_MODULES})