aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLeandro A. F. Pereira <leandro@hardinfo.org>2012-12-31 03:06:17 -0800
committerLeandro A. F. Pereira <leandro@hardinfo.org>2012-12-31 03:06:17 -0800
commitf4b4651e372d4369e4a62e7ccfe357048b171f70 (patch)
treeb928511b9dc7b6b7ceed8ff791b05c6e342c3ad9 /CMakeLists.txt
parent226097e9cbafb913636e5d40536009bf53f2a778 (diff)
parent242c55c39e10f490777409521c2c78c9a860fcc0 (diff)
Merge pull request #6 from hasufell/master
fix building with clang and desktop file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a320668..f1ea09f4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,6 +46,8 @@ endif()
message(STATUS "Building HardInfo for architecture: ${HARDINFO_OS}-${HARDINFO_ARCH}")
+add_definitions("-std=gnu89")
+
include(FindPkgConfig)
pkg_check_modules(GTK REQUIRED gtk+-2.0>=2.10 glib-2.0>=2.10 gthread-2.0>=2.10 gmodule-export-2.0>=2.10)
pkg_check_modules(LIBSOUP libsoup-2.4>=2.24)