aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBurt P <pburt0@gmail.com>2019-08-10 23:11:21 -0500
committerLeandro A. F. Pereira <leandro@hardinfo.org>2019-08-14 20:02:42 -0700
commitd17909c82b03ad0427a285c66766421751546c42 (patch)
tree485588a0822984d437fcd22ed9f23f441760ca72 /CMakeLists.txt
parent30508a10bf269e5ca06226fb50c86f5249cc746a (diff)
Benchmark: fixes, user_note, verifiable test data
* fix zlib display order * fix cryptohash MiB/s calculation * revision and params for other benchmarks * allow attaching user note to bench result with -u * don't inlcude the new result value bits if they are empty/invalid in bench_value_to_str(). bench_value_from_str() doesn't need to be modified. * bench_results: clean old result cpu name for x86 * use problem_marker() from dmi_memory to mark old version bench results * benchmark: verifiable test data size and content - The test data benchmark.data is stored in a file that could be edited to change the size or content. /* to guarantee size */ gchar *get_test_data(gsize min_size); /* to checksum content */ char *md5_digest_str(const char *data, unsigned int len); Signed-off-by: Burt P <pburt0@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ef4f8a9f..309614f7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -173,6 +173,7 @@ set(MODULE_network_SOURCES
)
set(MODULE_benchmark_SOURCES_GTKANY
modules/benchmark.c
+ modules/benchmark/bench_util.c
modules/benchmark/blowfish.c
modules/benchmark/blowfish2.c
modules/benchmark/cryptohash.c
@@ -208,6 +209,7 @@ set_source_files_properties(
set_source_files_properties(
modules/devices/dmi_memory.c
# modules/devices/spd-decode.c
+ hardinfo/problem_marker.c
PROPERTIES
COMPILE_FLAGS "-std=c99 -Wall -Wextra -Wno-unused-function -Wno-deprecated-declarations -Wno-switch"
)
@@ -266,6 +268,8 @@ add_executable(hardinfo
hardinfo/hardinfo.c
hardinfo/socket.c
hardinfo/util.c
+ hardinfo/gg_key_file_parse_string_as_value.c
+ hardinfo/problem_marker.c
hardinfo/vendor.c
hardinfo/info.c
hardinfo/cpu_util.c
@@ -302,6 +306,8 @@ add_executable(hardinfo
hardinfo/hardinfo.c
hardinfo/socket.c
hardinfo/util.c
+ hardinfo/gg_key_file_parse_string_as_value.c
+ hardinfo/problem_marker.c
hardinfo/vendor.c
hardinfo/info.c
hardinfo/cpu_util.c