aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBurt P <pburt0@gmail.com>2019-07-13 11:58:28 -0500
committerLeandro A. F. Pereira <leandro@hardinfo.org>2019-07-29 19:44:59 -0700
commit4fb64a41f4d74e3de672f984fa2617e54ad68d2a (patch)
treee05990283308606312adbe4cb6beaf1eaaaf8f54 /CMakeLists.txt
parent0dca7a1e165cdffa0065455b377d2658f33f4ea2 (diff)
uri_handler functions from sysobj
This allows link clicks to be intercepted so that they might be used by the application internally before falling back to the system uri handler. I've also found the default GTK label link handler to be unreliable outside of GNOME Shell, and this will use xdg-open instead. Signed-off-by: Burt P <pburt0@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8bbf301c..8bbdd837 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,6 +98,7 @@ include_directories(
${CMAKE_SOURCE_DIR}/includes/${HARDINFO_ARCH}
${CMAKE_SOURCE_DIR}/deps/uber-graph
${CMAKE_SOURCE_DIR}/deps/sysobj_early/include
+ ${CMAKE_SOURCE_DIR}/deps/sysobj_early/gui
${CMAKE_BINARY_DIR}
${GTK_INCLUDE_DIRS}
${LIBSOUP_INCLUDE_DIRS}
@@ -216,6 +217,7 @@ endforeach()
add_library(sysobj_early STATIC
deps/sysobj_early/src/gg_slist.c
deps/sysobj_early/src/strstr_word.c
+ deps/sysobj_early/gui/uri_handler.c
)
set_target_properties(sysobj_early PROPERTIES COMPILE_FLAGS "-std=c99 -Wall -Wextra -Wno-parentheses -Wno-unused-function")