aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBurt P <pburt0@gmail.com>2019-07-25 20:43:25 -0500
committerLeandro A. F. Pereira <leandro@hardinfo.org>2019-07-29 19:44:59 -0700
commit6938cbfd0c8d64aa93633fc7423879de757fd45c (patch)
tree359dd94243c72f29da8d848dbe5f23dd84b35fbc /CMakeLists.txt
parent9d043ceb42468af2f18b823e7dd5d026ef24b0b1 (diff)
replace idle_free() with auto_free() from sysobj
* auto_free() works in both report mode and gui mode. * auto_free() only creates one recuring event for the whole system rather than idle_free()'s one event per call. * auto_free_ex() allows specifying the free function to use. * auto_free() is thread-aware, free_auto_free_thread_final() can be used to clean up on thread exit. * auto_free() has some tweakability. Signed-off-by: Burt P <pburt0@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8bbdd837..e0749f9e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -217,6 +217,7 @@ endforeach()
add_library(sysobj_early STATIC
deps/sysobj_early/src/gg_slist.c
deps/sysobj_early/src/strstr_word.c
+ deps/sysobj_early/src/auto_free.c
deps/sysobj_early/gui/uri_handler.c
)
set_target_properties(sysobj_early PROPERTIES COMPILE_FLAGS "-std=c99 -Wall -Wextra -Wno-parentheses -Wno-unused-function")