aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLeandro Pereira <leandro@hardinfo.org>2017-08-14 09:48:34 -0700
committerLeandro Pereira <leandro@hardinfo.org>2017-08-14 09:48:34 -0700
commita461a29bd60928e14cc8ff311734ccd1dae5ffd4 (patch)
treeb5083378cef3749bc66cf4fdec90376af8465d79 /CMakeLists.txt
parent3d38d4bb4a68a3e0d7529d0f537ad9d33588db42 (diff)
Begin getting rid of callbacks returning strings
Strings were never a good choice to begin with. However, with the efforts to improve translatability, they became even worse. This is an attempt to clean up the current mess and provide a more structured way for modules to commmunicate with the shell. The Computer module has been partially converted and changes will be provided next. It's partially converted since some of its information is still stored as strings. The Shell still only understands strings; that's why the structured data is converted to a string the way it is. Once all modules are converted, the Shell can be modified to handle struct Info directly without having to parse the .ini-like strings.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 439a58a6..d82b2927 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -245,6 +245,7 @@ add_executable(hardinfo
hardinfo/socket.c
hardinfo/util.c
hardinfo/vendor.c
+ hardinfo/info.c
shell/callbacks.c
shell/iconcache.c
shell/menu.c