aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBurt P <pburt0@gmail.com>2018-10-27 12:58:17 -0500
committerLeandro A. F. Pereira <leandro@hardinfo.org>2018-12-02 02:07:23 -0800
commit95e53cda009f498a88f64ef71803a168cb08856c (patch)
treedacc6f84e8ed93db85708b1f58df8705a5d52f8a /CMakeLists.txt
parent58a9f093fc830ad3d17a77423136be30db631934 (diff)
enable and fix some warnings
Part of (#298). Signed-off-by: Burt P <pburt0@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b2f82fa0..d7dbd98d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -219,6 +219,16 @@ add_library(uber-graph STATIC
)
endif()
+set_source_files_properties(
+ hardinfo/usb_util.c
+ hardinfo/pci_util.c
+ hardinfo/gpu_util.c
+ hardinfo/cpu_util.c
+ hardinfo/x_util.c
+ PROPERTIES
+ COMPILE_FLAGS "-Wall -Wextra -Wno-parentheses -Wno-unused-function"
+)
+
if (HARDINFO_GTK3)
add_executable(hardinfo
hardinfo/usb_util.c