aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLeandro Pereira <leandro@hardinfo.org>2020-08-13 08:25:07 -0700
committerLeandro Pereira <leandro@hardinfo.org>2020-08-13 08:25:43 -0700
commit05576964c55469bce7abc55b45b8c3eaf43a501f (patch)
treeabe15658ddfd0fde00e63d7163d177ae80681494 /CMakeLists.txt
parenta376e656e747059d837b97d0f224c5b825c98f7d (diff)
Make json-glib a requirement regardless if libsoup has been found
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b6719616..15421f46 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -89,9 +89,7 @@ else()
endif()
pkg_check_modules(LIBSOUP libsoup-2.4>=2.42)
-if (LIBSOUP_FOUND)
- pkg_check_modules(JSON_GLIB REQUIRED json-glib-1.0)
-endif()
+pkg_check_modules(JSON_GLIB REQUIRED json-glib-1.0)
pkg_check_modules(X11 REQUIRED x11)