aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLeandro Pereira <leandro@hardinfo.org>2016-07-30 10:26:05 -0300
committerLeandro Pereira <leandro@hardinfo.org>2016-07-30 10:33:42 -0300
commit91072682c01501874ba6d8c74d3ded152db2951b (patch)
tree25363488983043caa57cad306d60bf78661246d4 /CMakeLists.txt
parentba5a7e1b4ccd0a65b72532252ca922b8dea4cce3 (diff)
Remove remote feature
This has no encryption, SSH credentials are stored in plain text, etc.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 88d8a5c9..74d16b32 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -146,12 +146,6 @@ foreach (_module ${HARDINFO_MODULES})
set_target_properties(${_module} PROPERTIES PREFIX "")
endforeach()
-add_library(hardinfo-remote STATIC
- remote/remote.c
- remote/ssh-conn.c
- remote/xmlrpc-client.c
- remote/xmlrpc-server.c
-)
add_library(hardinfo-shell STATIC
shell/callbacks.c
shell/iconcache.c
@@ -176,9 +170,6 @@ target_link_libraries(hardinfo
hardinfo-shell
m
)
-target_link_libraries(hardinfo-shell
- hardinfo-remote
-)
configure_file(config.h.cmake ${CMAKE_BINARY_DIR}/config.h @ONLY)
configure_file(hardinfo.desktop.cmake ${CMAKE_BINARY_DIR}/hardinfo.desktop @ONLY)