aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorhwspeedy <ns@bigbear.dk>2024-02-20 03:26:13 +0100
committerhwspeedy <ns@bigbear.dk>2024-02-20 03:26:13 +0100
commitd67f91e17f2056644df03fee33cd97b58b054374 (patch)
tree795b5f9aa219b4b3dc14535e796bb555ceee64af /CMakeLists.txt
parent6e6aeff7cf5db2e6131a907350d30793147ad8c4 (diff)
PR569 - bp0 add Internal Network Benchmark - FIX GLIB VER
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8902a9b1..c0c724ed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -84,9 +84,7 @@ add_definitions("-Wformat")
add_definitions("-Wformat-security")
set(PACKAGE_LIBSOUP2_MINVERSION 2.42)
-#Actually needed for save settings, steal_pointer - FIXME
-set(PACKAGE_LIBGLIB2_MINVERSION 2.44)
-#set(PACKAGE_LIBGLIB2_MINVERSION 2.28)
+set(PACKAGE_LIBGLIB2_MINVERSION 2.24)
###################################DISTRO CHANGES###############################
#Please add all distro relates stuff here
@@ -148,9 +146,6 @@ if(${distro}${disversion} MATCHES "Oracle6*")
set(HARDINFO2_GTK3 0)
#old deprecated version - but ok
set(PACKAGE_LIBSOUP2_MINVERSION 2.34.3)
- #save settings disabled, steal_pointer disabled
- set(PACKAGE_LIBGLIB2_MINVERSION 2.28.8)
- message("-- Low GLIB2 version 2.28.0")
endif()
#debian 8
@@ -304,6 +299,7 @@ set(MODULE_benchmark_SOURCES_GTKANY
modules/benchmark/sha1.c
modules/benchmark/zlib.c
modules/benchmark/sysbench.c
+ modules/benchmark/iperf3.c
)
set(MODULE_benchmark_SOURCES_GTK2
modules/benchmark/drawing.c