summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBurt P <pburt0@gmail.com>2017-08-18 02:14:47 -0500
committerLeandro A. F. Pereira <leandro@hardinfo.org>2018-03-12 09:20:16 -0700
commitfdb1a05b6b5c84b67e3df107288f5046b763647e (patch)
tree57a18f80dac7cd11b5a571eef0d3a69ae096edcc /CMakeLists.txt
parent9154a9ab51a62180298dbd71c3cdac3f07f7b2a1 (diff)
usb_util.c
A set of functions for getting information for a single USB device, or a list of all devices. The only implemented method is using `lsusb`, which is slow. A method using sysfs would be much better. The existing sysfs and procfs methods in devices/usb.c do not appear to work, so it would have to be something new. devices/usb.c modified to use usb_util, but all the old code is still there. Signed-off-by: Burt P <pburt0@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8038aead..bc480146 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -214,6 +214,7 @@ endif()
if (HARDINFO_GTK3)
add_executable(hardinfo
+ hardinfo/usb_util.c
hardinfo/binreloc.c
hardinfo/expr.c
hardinfo/hardinfo.c
@@ -242,6 +243,7 @@ target_link_libraries(hardinfo
)
else()
add_executable(hardinfo
+ hardinfo/usb_util.c
hardinfo/binreloc.c
hardinfo/expr.c
hardinfo/hardinfo.c