summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBurt P <pburt0@gmail.com>2019-06-25 20:46:24 -0500
committerLeandro A. F. Pereira <leandro@hardinfo.org>2019-06-26 17:49:50 -0700
commit313754e4ed9cfd97afdcc2a95099fe704e4189ee (patch)
treef5b6b9cb5352ad67872f6287d0234a942f6f660d /CMakeLists.txt
parentb0665180d51f3ec6c9cfc1b98c0f6f8452304dbd (diff)
devices/dmi_memory.c: shell viewtype=1 version, other tweaks
* add -std=c99 for dmi_memory.c to use unicode * -std=c99 is picky about inline functions Signed-off-by: Burt P <pburt0@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ae01bbf..fc78df39 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -199,6 +199,12 @@ set_source_files_properties(
COMPILE_FLAGS "-O0"
)
+set_source_files_properties(
+ modules/devices/dmi_memory.c
+ PROPERTIES
+ COMPILE_FLAGS "-std=c99"
+)
+
foreach (_module ${HARDINFO_MODULES})
add_library(${_module} MODULE ${MODULE_${_module}_SOURCES})
set_target_properties(${_module} PROPERTIES PREFIX "")