summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLeandro Pereira <leandro@hardinfo.org>2017-07-02 22:12:10 -0700
committerLeandro Pereira <leandro@hardinfo.org>2017-07-02 22:12:38 -0700
commite9d69db8341ee7452ce4e8f8dc54e972b0390bfe (patch)
tree4b0304f6c9b0e4c68d599dfb7587a744650e8486 /CMakeLists.txt
parent03313957df7968ac0e7bf724f4d8484378aabb68 (diff)
Add zlib benchmark
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae29a99e..d0665ac9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,6 +59,8 @@ if(NOT HARDINFO_NOSYNC)
pkg_check_modules(LIBSOUP libsoup-2.4>=2.24)
endif()
+include(FindZLIB REQUIRED)
+
include_directories(
${CMAKE_SOURCE_DIR}
${CMAKE_SOURCE_DIR}/includes
@@ -66,6 +68,7 @@ include_directories(
${CMAKE_BINARY_DIR}
${GTK_INCLUDE_DIRS}
${LIBSOUP_INCLUDE_DIRS}
+ ${ZLIB_INCLUDE_DIRS}
)
link_directories(
${GTK_LIBRARY_DIRS}
@@ -134,6 +137,7 @@ set(MODULE_benchmark_SOURCES
modules/benchmark/nqueens.c
modules/benchmark/raytrace.c
modules/benchmark/sha1.c
+ modules/benchmark/zlib.c
)
set_source_files_properties(
@@ -173,6 +177,7 @@ target_link_libraries(hardinfo
${LIBSOUP_LIBRARIES}
hardinfo-shell
m
+ ${ZLIB_LIBRARIES}
)
configure_file(config.h.cmake ${CMAKE_BINARY_DIR}/config.h @ONLY)