summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLeandro Pereira <leandro@hardinfo.org>2020-05-18 19:21:12 -0700
committerLeandro Pereira <leandro@hardinfo.org>2020-05-18 19:21:12 -0700
commit551c0e1861536ce18572f049b647470e29656473 (patch)
tree29537008eef080189aa5f612ba5757247be2b115 /CMakeLists.txt
parent5e4530f4c177e8a5b1bb0d282be1e0f89f3fd80e (diff)
Only require json-glib if HARDINFO_NOSYNC is disabled
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68afed66..e2360eb0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,11 +88,10 @@ else()
endif()
if(NOT HARDINFO_NOSYNC)
- pkg_check_modules(LIBSOUP libsoup-2.4>=2.24)
+ pkg_check_modules(LIBSOUP REQUIRED libsoup-2.4>=2.24)
+ pkg_check_modules(JSON_GLIB REQUIRED json-glib-1.0)
endif()
-pkg_check_modules(JSON_GLIB REQUIRED json-glib-1.0>=1.4)
-
pkg_check_modules(X11 REQUIRED x11)
include(FindZLIB REQUIRED)