summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLeandro Pereira <leandro@hardinfo.org>2020-05-09 11:12:24 -0700
committerLeandro Pereira <leandro@hardinfo.org>2020-05-09 11:12:24 -0700
commita14313aec10633f6c3a16eb2e80a73e406ca5a01 (patch)
tree06b1782000866280d6477de1b85e627c64a7965d /CMakeLists.txt
parent539a4f019cf68ca93452e1b6d384daf823271d23 (diff)
Require json-glib to build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index acfdfeb0..ae4d12fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -89,6 +89,8 @@ if(NOT HARDINFO_NOSYNC)
pkg_check_modules(LIBSOUP libsoup-2.4>=2.24)
endif()
+pkg_check_modules(JSON_GLIB REQUIRED json-glib-1.0>=1.4)
+
pkg_check_modules(X11 REQUIRED x11)
include(FindZLIB REQUIRED)
@@ -105,11 +107,13 @@ include_directories(
${LIBSOUP_INCLUDE_DIRS}
${ZLIB_INCLUDE_DIRS}
${X11_INCLUDE_DIRS}
+ ${JSON_GLIB_INCLUDE_DIRS}
)
link_directories(
${GTK_LIBRARY_DIRS}
${LIBSOUP_LIBRARY_DIRS}
${X11_LIBRARY_DIRS}
+ ${JSON_GLIB_LIBRARY_DIRS}
)
set(HARDINFO_MODULES
@@ -349,6 +353,7 @@ target_link_libraries(hardinfo
m
${ZLIB_LIBRARIES}
${X11_LIBRARIES}
+ ${JSON_GLIB_LIBRARIES}
)
endif()