summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLeandro Pereira <leandro@hardinfo.org>2020-05-25 11:54:43 -0700
committerLeandro Pereira <leandro@hardinfo.org>2020-05-25 11:54:43 -0700
commitb75e6edad9e541da77798155560aefdfbc5357c7 (patch)
treec939a3c6d34de3ab44746737427eab1bd1e5a818 /CMakeLists.txt
parent3e3e9a11bc73f58e9b6bc24efc89e99ad1a73193 (diff)
Ensure benchmark.so is linked against json-glib
This is a workaround; the problem lies elsewhere.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 85b04ceb..2752b962 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -231,6 +231,7 @@ foreach (_module ${HARDINFO_MODULES})
add_library(${_module} MODULE ${MODULE_${_module}_SOURCES})
set_target_properties(${_module} PROPERTIES PREFIX "")
endforeach()
+target_link_libraries(benchmark ${JSON_GLIB_LIBRARIES})
add_library(sysobj_early STATIC
deps/sysobj_early/src/gg_slist.c