summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBurt P <pburt0@gmail.com>2019-08-18 16:41:29 -0500
committerLeandro A. F. Pereira <leandro@hardinfo.org>2019-08-18 23:49:29 +0200
commitf5c8d890bd22a12cc561ed231c92455a47b9269a (patch)
treed121c59593e1e2753ac6967ddcdaa1e89b364936 /CMakeLists.txt
parentd285b2f6209e6ced22482d15e3a78e67731e8bf7 (diff)
Link sysobj_early with -whole-archive
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e41cbf4a..e43195db 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -295,7 +295,7 @@ add_executable(hardinfo
shell/loadgraph-uber.c
)
target_link_libraries(hardinfo
- sysobj_early
+ -Wl,-whole-archive sysobj_early -Wl,-no-whole-archive
uber-graph
${GTK_LIBRARIES}
${LIBSOUP_LIBRARIES}
@@ -333,7 +333,7 @@ add_executable(hardinfo
shell/loadgraph.c
)
target_link_libraries(hardinfo
- sysobj_early
+ -Wl,-whole-archive sysobj_early -Wl,-no-whole-archive
${GTK_LIBRARIES}
${LIBSOUP_LIBRARIES}
m