aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorhwspeedy <ns@bigbear.dk>2024-03-03 05:33:32 +0100
committerhwspeedy <ns@bigbear.dk>2024-03-03 05:33:32 +0100
commit1ababda27ac03e3b9ad8aeb824658936df68d8c5 (patch)
tree69fc30e793bcc19a22b3b10c44da1afd60d23193 /CMakeLists.txt
parent037600fd451ac42462754b55a6f519e407ba8b99 (diff)
PACKAGING - debian/redhat source package fixing - add script to create debian source packagerelease-2.0.12
tools/create_debian_source.sh
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4ee5c461..28182192 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -134,6 +134,11 @@ else()
endif()
#Put it together
string(REPLACE " " "_" CPACK_PACKAGE_FILE_NAME "hardinfo${PACKAGE_DELIMITER}${PACKAGE_DISTRO}${PACKAGE_ARCHITECTURE}")
+if(${RPM})
+ string(REPLACE " " "_" CPACK_SOURCE_PACKAGE_FILE_NAME "hardinfo${PACKAGE_DELIMITER}${HARDINFO2_VERSION}.src")
+else()
+ string(REPLACE " " "_" CPACK_SOURCE_PACKAGE_FILE_NAME "hardinfo-${HARDINFO2_VERSION}")
+endif()
message("-- Found Package Target ${CPACK_PACKAGE_FILE_NAME}")
message("-- Found Package Version ${CPACK_PACKAGE_VERSION}")
@@ -522,11 +527,16 @@ install(FILES pixmaps/hardinfo2.png
#Please update here for building packages
#keep package name as hardinfo to allow for upgrading in distro
SET(CPACK_PACKAGE_NAME "hardinfo")
+SET(CPACK_SOURCE_PACKAGE_NAME "hardinfo")
SET(CPACK_PACKAGE_HOMEPAGE_URL "https://www.hardinfo2.org")
if(${RPM})
+ SET(CPACK_SOURCE_IGNORE_FILES "/build/;/.git/;/.github/;.gitignore;.gitmodules;*.po.old;*~;*.mo;*.dsc;/debian/")
+ SET(CPACK_SOURCE_GENERATOR "RPM")
SET(CPACK_GENERATOR "RPM")
SET(PACKAGE_GTK2 "libgtk-2-0")
else()
+ SET(CPACK_SOURCE_IGNORE_FILES "/build/;/.git/;/.github/;.gitignore;.gitmodules;*.po.old;*~;*.mo")
+ SET(CPACK_SOURCE_GENERATOR "TGZ")
SET(CPACK_GENERATOR "DEB")
SET(PACKAGE_GTK2 "libgtk2.0-0")
endif()