aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorLeandro Pereira <leandro@linuxmag.com.br>2004-06-14 21:33:25 -0300
committerSimon Quigley <tsimonq2@ubuntu.com>2017-06-19 14:38:31 -0500
commit7d65a12d6431f72e601ea1d0c3ef5d09af8bfb96 (patch)
tree7ad1761adce3212a13e5342a54865e31b917f18b /debian/rules
parent0864b0a8e6f0b0983c3536931cfbad1414137d6b (diff)
parent8c1612d32c5682a86216adb8c8d11ce715fe5475 (diff)
Import Debian changes 0.3.6-5
hardinfo (0.3.6-5) unstable; urgency=high * Add Amd64 support (closes: #253935). Thanks to Kurt Roeckx <Q@ping.be> * Close duplicate "doesn't work with newer pciutils" bug (closes: #254018). hardinfo (0.3.6-4) unstable; urgency=high * Fixed segfault on startup (closes: #242843). Thanks to Remco van de Meent <remco@debian.org> hardinfo (0.3.6-3) unstable; urgency=high * Added Debian menu entry icon. * Fixed some misc packaging bugs. * Changed package description. hardinfo (0.3.6-2) unstable; urgency=low * Sync with upstream sources. * Disabled "Network" tab. hardinfo (0.3.6-1) unstable; urgency=high * Sync with upstream sources. hardinfo (0.3.5-1) unstable; urgency=high * Sync with upstream sources. hardinfo (0.3.4-1) unstable; urgency=high * Sync with upstream sources. hardinfo (0.3.3-1) unstable; urgency=low * Sync with upstream sources. hardinfo (0.3.2-1) unstable; urgency=low * Sync with upstream sources. hardinfo (0.3.1-1) unstable; urgency=low * Sync with upstream sources. hardinfo (0.3-1) unstable; urgency=low * Initial Release.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules95
1 files changed, 95 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..9d2c0f5b
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,95 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ ./configure
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ $(MAKE)
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/hardinfo.
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/hardinfo
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs ChangeLog
+ dh_installdocs
+# dh_installexamples
+ dh_install
+ dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman debian/hardinfo.1
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure