aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt2
-rw-r--r--hardinfo.desktop.cmake4
-rw-r--r--hardinfo/util.c2
3 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a320668..f1ea09f4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,6 +46,8 @@ endif()
message(STATUS "Building HardInfo for architecture: ${HARDINFO_OS}-${HARDINFO_ARCH}")
+add_definitions("-std=gnu89")
+
include(FindPkgConfig)
pkg_check_modules(GTK REQUIRED gtk+-2.0>=2.10 glib-2.0>=2.10 gthread-2.0>=2.10 gmodule-export-2.0>=2.10)
pkg_check_modules(LIBSOUP libsoup-2.4>=2.24)
diff --git a/hardinfo.desktop.cmake b/hardinfo.desktop.cmake
index bf73dd12..7d5a25f4 100644
--- a/hardinfo.desktop.cmake
+++ b/hardinfo.desktop.cmake
@@ -2,8 +2,8 @@
Name=System Profiler and Benchmark
Name[pt_BR]=Informações e Testes do Sistema
Name[es]=Informacion y Rendimiento del Sistema
-Exec=@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_BINDIR@/hardinfo
-Icon=@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_DATAROOTDIR@/hardinfo/pixmaps/logo.png
+Exec=@CMAKE_INSTALL_FULL_BINDIR@/hardinfo
+Icon=@CMAKE_INSTALL_FULL_DATAROOTDIR@/hardinfo/pixmaps/logo.png
Terminal=false
Type=Application
StartupNotify=true
diff --git a/hardinfo/util.c b/hardinfo/util.c
index 1640be8b..3c083b34 100644
--- a/hardinfo/util.c
+++ b/hardinfo/util.c
@@ -1368,7 +1368,7 @@ moreinfo_lookup_with_prefix(gchar *prefix, gchar *key)
{
if (G_UNLIKELY(!_moreinfo)) {
DEBUG("moreinfo not initialized");
- return;
+ return 0;
}
if (prefix) {