aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/make-build-reproducable.patch34
-rw-r--r--debian/patches/series1
3 files changed, 36 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 4f005bf9..8715f054 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ hardinfo (0.5.1+git20170620-2) UNRELEASED; urgency=high
* Fix build on ppc64el (Closes: #865776).
* Update FSF address to new one in debian/changelog's LGPL-2.1+ stanza.
+ * Make the build reproducible (Closes: #833379).
-- Simon Quigley <tsimonq2@ubuntu.com> Wed, 05 Jul 2017 06:35:11 -0500
diff --git a/debian/patches/make-build-reproducable.patch b/debian/patches/make-build-reproducable.patch
new file mode 100644
index 00000000..ef85bfa8
--- /dev/null
+++ b/debian/patches/make-build-reproducable.patch
@@ -0,0 +1,34 @@
+Description: Make HardInfo reproducable.
+ This patch removes the "Compiled on:" text when running "hardinfo --version"
+ because it does not show any useful information at the moment, and causes
+ HardInfo to fail reproducibility tests.
+Author: Simon Quigley <tsimonq2@ubuntu.com>
+Bug-Debian: https://bugs.debian.org/833379
+Reviewed-by: Mattia Rizzolo <mattia@debian.org>
+Last-Update: 2017-07-14
+--- a/config.h.cmake
++++ b/config.h.cmake
+@@ -5,9 +5,6 @@
+
+ #define ARCH "ARCH_@HARDINFO_ARCH@"
+ #define OS "@HARDINFO_OS@"
+-#define PLATFORM OS "-" ARCH
+-#define KERNEL "@CMAKE_SYSTEM_VERSION@"
+-#define HOSTNAME ""
+ #define ARCH_@HARDINFO_ARCH@
+
+ #define LIBDIR "@CMAKE_INSTALL_LIBDIR@"
+--- a/hardinfo/hardinfo.c
++++ b/hardinfo/hardinfo.c
+@@ -52,10 +52,9 @@ int main(int argc, char **argv)
+ " BinReloc enabled: %s\n"
+ " Data prefix: %s\n"
+ " Library prefix: %s\n"
+- " Compiled on: %s %s (%s)\n"),
+ RELEASE ? _("Yes") : "No (" VERSION ")", ARCH,
+ ENABLE_BINRELOC ? _("Yes") : _("No"),
+- PREFIX, LIBPREFIX, PLATFORM, KERNEL, HOSTNAME);
++ PREFIX, LIBPREFIX);
+
+ DEBUG(" Debugging is enabled.");
+
diff --git a/debian/patches/series b/debian/patches/series
index b5d1bcf9..0f96bc2c 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
+make-build-reproducable.patch
fix-ppc64el-ftbfs.patch
glibc-version.patch