aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 103359df..f4a970e3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -203,7 +203,7 @@ set_source_files_properties(
modules/devices/dmi_memory.c
# modules/devices/spd-decode.c
PROPERTIES
- COMPILE_FLAGS "-std=c99 -Wno-deprecated-declarations"
+ COMPILE_FLAGS "-std=c99 -Wall -Wextra -Wno-unused-function -Wno-deprecated-declarations -Wno-switch"
)
foreach (_module ${HARDINFO_MODULES})