aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b2f82fa0..d7dbd98d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -219,6 +219,16 @@ add_library(uber-graph STATIC
)
endif()
+set_source_files_properties(
+ hardinfo/usb_util.c
+ hardinfo/pci_util.c
+ hardinfo/gpu_util.c
+ hardinfo/cpu_util.c
+ hardinfo/x_util.c
+ PROPERTIES
+ COMPILE_FLAGS "-Wall -Wextra -Wno-parentheses -Wno-unused-function"
+)
+
if (HARDINFO_GTK3)
add_executable(hardinfo
hardinfo/usb_util.c