aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68afed66..e2360eb0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,11 +88,10 @@ else()
endif()
if(NOT HARDINFO_NOSYNC)
- pkg_check_modules(LIBSOUP libsoup-2.4>=2.24)
+ pkg_check_modules(LIBSOUP REQUIRED libsoup-2.4>=2.24)
+ pkg_check_modules(JSON_GLIB REQUIRED json-glib-1.0)
endif()
-pkg_check_modules(JSON_GLIB REQUIRED json-glib-1.0>=1.4)
-
pkg_check_modules(X11 REQUIRED x11)
include(FindZLIB REQUIRED)