aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 875041d0..ef4f8a9f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -120,9 +120,10 @@ set(HARDINFO_MODULES
set(HARDINFO_RESOURCES
"data/benchmark.conf"
"data/benchmark.data"
- "data/vendor.ids"
+ "deps/sysobj_early/data/vendor.ids"
"deps/sysobj_early/data/sdcard.ids"
"deps/sysobj_early/data/usb.ids"
+ "deps/sysobj_early/data/arm.ids"
)
set(HARDINFO_MANPAGES
@@ -221,6 +222,9 @@ add_library(sysobj_early STATIC
deps/sysobj_early/src/strstr_word.c
deps/sysobj_early/src/auto_free.c
deps/sysobj_early/src/util_ids.c
+ deps/sysobj_early/src/util_sysobj.c
+ deps/sysobj_early/src/appf.c
+ deps/sysobj_early/src/nice_name.c
deps/sysobj_early/gui/uri_handler.c
)
set_target_properties(sysobj_early PROPERTIES COMPILE_FLAGS "-std=c99 -Wall -Wextra -Wno-parentheses -Wno-unused-function")