aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 60d70903..f2a9ea15 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -324,7 +324,7 @@ set_source_files_properties(
hardinfo2/problem_marker.c
hardinfo2/hinote_util.c
PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-unused-function -Wno-switch -Werror=implicit-function-declaration"
+ COMPILE_FLAGS "-std=c99 -Wall -Wextra -Wno-unused-function -Wno-switch -Werror=implicit-function-declaration"
)
foreach (_module ${HARDINFO2_MODULES})
@@ -353,7 +353,7 @@ add_library(sysobj_early STATIC
deps/sysobj_early/src/format_early.c
deps/sysobj_early/src/cpubits.c
)
-set_target_properties(sysobj_early PROPERTIES COMPILE_FLAGS "-Wall -Wextra -Wno-parentheses -Wno-unused-function -Werror=implicit-function-declaration")
+set_target_properties(sysobj_early PROPERTIES COMPILE_FLAGS "-std=c99 -Wall -Wextra -Wno-parentheses -Wno-unused-function -Werror=implicit-function-declaration")
target_link_libraries(sysobj_early m)
if (HARDINFO2_GTK3)