aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e41cbf4a..e43195db 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -295,7 +295,7 @@ add_executable(hardinfo
shell/loadgraph-uber.c
)
target_link_libraries(hardinfo
- sysobj_early
+ -Wl,-whole-archive sysobj_early -Wl,-no-whole-archive
uber-graph
${GTK_LIBRARIES}
${LIBSOUP_LIBRARIES}
@@ -333,7 +333,7 @@ add_executable(hardinfo
shell/loadgraph.c
)
target_link_libraries(hardinfo
- sysobj_early
+ -Wl,-whole-archive sysobj_early -Wl,-no-whole-archive
${GTK_LIBRARIES}
${LIBSOUP_LIBRARIES}
m