aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/aarch64.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/aarch64.diff')
-rw-r--r--debian/patches/aarch64.diff18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/patches/aarch64.diff b/debian/patches/aarch64.diff
new file mode 100644
index 00000000..655bcf54
--- /dev/null
+++ b/debian/patches/aarch64.diff
@@ -0,0 +1,18 @@
+Description: Build for AArch64, using the ARM configuration. Fixes FTBFS on arm64.
+ Inspired by Matthias Klose's initial patch fixing this problem.
+Author: Simon Quigley <tsimonq2@ubuntu.com>
+Bug-Debian: http://bugs.debian.org/779465
+Last-Update: 2017-06-19
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -29,6 +29,8 @@ elseif(${CMAKE_HOST_SYSTEM_PROCESSOR} MA
+ set(HARDINFO_ARCH "parisc")
+ elseif(${CMAKE_HOST_SYSTEM_PROCESSOR} MATCHES "sparc{32,64}")
+ set(HARDINFO_ARCH "sparc")
++elseif(${CMAKE_HOST_SYSTEM_PROCESSOR} MATCHES "aarch64*")
++ set(HARDINFO_ARCH "aarch64")
+ elseif(${CMAKE_HOST_SYSTEM_PROCESSOR} MATCHES "arm.*")
+ set(HARDINFO_ARCH "arm")
+ elseif(${CMAKE_HOST_SYSTEM_PROCESSOR} MATCHES "ia64")