summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2008-02-13 21:52:56 +0000
committerRuss Allbery <rra@stanford.edu>2008-02-13 21:52:56 +0000
commit4a3486cc75336c5324b7f970ff200381cb9b80ef (patch)
tree97c66d063617e0d68366703ab56f2af67cca202f
parentc3cef39c9f03918eb2d6e209ceeff0dc64b80ec7 (diff)
Release 0.8.
-rw-r--r--NEWS2
-rw-r--r--README2
-rw-r--r--TODO13
-rw-r--r--configure.ac2
4 files changed, 16 insertions, 3 deletions
diff --git a/NEWS b/NEWS
index 9ddd94e..ae0ef28 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,6 @@
User-Visible wallet Changes
-wallet 0.8 (unreleased)
+wallet 0.8 (2008-02-13)
Fix the wallet client to use check instead of exists.
diff --git a/README b/README
index d204416..3bc8df5 100644
--- a/README
+++ b/README
@@ -1,4 +1,4 @@
- wallet release 0.7
+ wallet release 0.8
(secure data management system)
Written by Russ Allbery <rra@stanford.edu>
diff --git a/TODO b/TODO
index 0778867..d12267c 100644
--- a/TODO
+++ b/TODO
@@ -6,6 +6,9 @@ Release 1.0:
* Add a test suite for kasetkey.
+* Rewrite the server checks to avoid using IO::String, since one of the
+ tests already requires Perl 5.8's internal string handling.
+
* Add POD coverage testing using Test::POD::Coverage for the server
modules.
@@ -56,6 +59,16 @@ Release 1.0:
an ACL without having to write it into the database. Redo default ACL
creation using that functionality.
+* The wallet client currently sets sync kaserver whenever writing a keytab
+ to a srvtab. This is correct for sites using kaserver and wrong for
+ everyone else. Remove or rethink this once Stanford's kaserver
+ migration is over.
+
+* The wallet client currently hard-codes a kvno of 0 in srvtabs, which is
+ correct for how kasetkey works but probably isn't correct for people
+ using Heimdal or MIT to serve both K4 and K5 from the same KDC. Rethink
+ once Stanford's kaserver migration is over.
+
Future work:
* Write a conventions document for ACL naming, object naming, and similar
diff --git a/configure.ac b/configure.ac
index 3ef580a..7530691 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,7 @@ dnl See LICENSE for licensing terms.
AC_REVISION([$Revision$])
AC_PREREQ([2.61])
-AC_INIT([wallet], [0.7], [rra@stanford.edu])
+AC_INIT([wallet], [0.8], [rra@stanford.edu])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_LIBOBJ_DIR([portable])
AM_INIT_AUTOMAKE([1.10])