diff options
author | Russ Allbery <rra@stanford.edu> | 2010-02-09 21:01:33 -0800 |
---|---|---|
committer | Russ Allbery <rra@stanford.edu> | 2010-02-09 21:01:33 -0800 |
commit | a556c732806da87d06bb787565e12240ea39b553 (patch) | |
tree | 960b3a5e8fc32b4cb5399d56d20a3db077ef86b8 | |
parent | ff2d5ac3c63af9833d884d4840c772e60e45da7d (diff) |
Stop doing Autoconf substitution on some test suite code
Anything that only was using substitution for the paths to the build
tree now uses $SOURCE and $BUILD instead. Stop doing substitution.
Also fix tests/data/cmd-wrapper to use the environment variables.
-rw-r--r-- | .gitignore | 7 | ||||
-rw-r--r-- | configure.ac | 6 | ||||
-rwxr-xr-x[-rw-r--r--] | tests/client/pod-t (renamed from tests/client/pod-t.in) | 0 | ||||
-rwxr-xr-x[-rw-r--r--] | tests/data/cmd-wrapper (renamed from tests/data/cmd-wrapper.in) | 5 | ||||
-rwxr-xr-x[-rw-r--r--] | tests/server/admin-t (renamed from tests/server/admin-t.in) | 0 | ||||
-rwxr-xr-x[-rw-r--r--] | tests/server/backend-t (renamed from tests/server/backend-t.in) | 0 | ||||
-rwxr-xr-x[-rw-r--r--] | tests/server/keytab-t (renamed from tests/server/keytab-t.in) | 0 | ||||
-rwxr-xr-x[-rw-r--r--] | tests/server/pod-t (renamed from tests/server/pod-t.in) | 0 |
8 files changed, 2 insertions, 16 deletions
@@ -18,15 +18,12 @@ /perl/t/data/test.krbtype /tests/client/basic-t /tests/client/full-t -/tests/client/pod-t /tests/client/prompt-t -/tests/data/cmd-wrapper /tests/data/full.conf /tests/data/test.keytab /tests/data/test.password /tests/data/test.principal /tests/data/test.krbtype -/tests/kasetkey/basic-t /tests/portable/asprintf-t /tests/portable/mkstemp-t /tests/portable/setenv-t @@ -34,10 +31,6 @@ /tests/portable/strlcat-t /tests/portable/strlcpy-t /tests/runtests -/tests/server/admin-t -/tests/server/backend-t -/tests/server/keytab-t -/tests/server/pod-t /tests/util/concat-t /tests/util/messages-krb5-t /tests/util/messages-t diff --git a/configure.ac b/configure.ac index c897775..664c6f7 100644 --- a/configure.ac +++ b/configure.ac @@ -64,11 +64,5 @@ AC_CONFIG_HEADER([config.h]) AC_CONFIG_FILES([Makefile perl/Makefile.PL tests/data/full.conf]) AC_CONFIG_FILES([tests/client/basic-t], [chmod +x tests/client/basic-t]) AC_CONFIG_FILES([tests/client/full-t], [chmod +x tests/client/full-t]) -AC_CONFIG_FILES([tests/client/pod-t], [chmod +x tests/client/pod-t]) AC_CONFIG_FILES([tests/client/prompt-t], [chmod +x tests/client/prompt-t]) -AC_CONFIG_FILES([tests/data/cmd-wrapper], [chmod +x tests/data/cmd-wrapper]) -AC_CONFIG_FILES([tests/server/admin-t], [chmod +x tests/server/admin-t]) -AC_CONFIG_FILES([tests/server/backend-t], [chmod +x tests/server/backend-t]) -AC_CONFIG_FILES([tests/server/keytab-t], [chmod +x tests/server/keytab-t]) -AC_CONFIG_FILES([tests/server/pod-t], [chmod +x tests/server/pod-t]) AC_OUTPUT diff --git a/tests/client/pod-t.in b/tests/client/pod-t index 9963567..9963567 100644..100755 --- a/tests/client/pod-t.in +++ b/tests/client/pod-t diff --git a/tests/data/cmd-wrapper.in b/tests/data/cmd-wrapper index 7c7b342..79b1943 100644..100755 --- a/tests/data/cmd-wrapper.in +++ b/tests/data/cmd-wrapper @@ -3,7 +3,6 @@ # Wrapper around the standard wallet-backend script that sets the Perl INC # path and the WALLET_CONFIG environment variable appropriately. -WALLET_CONFIG='@abs_top_srcdir@/tests/data/wallet.conf' +WALLET_CONFIG="$SOURCE/data/wallet.conf" export WALLET_CONFIG -exec perl -I'@abs_top_srcdir@/perl' '@abs_top_srcdir@/server/wallet-backend' \ - -q "$@" +exec perl -I"$SOURCE/../perl" "$SOURCE/../server/wallet-backend" -q "$@" diff --git a/tests/server/admin-t.in b/tests/server/admin-t index 570dc52..570dc52 100644..100755 --- a/tests/server/admin-t.in +++ b/tests/server/admin-t diff --git a/tests/server/backend-t.in b/tests/server/backend-t index 2fc6a53..2fc6a53 100644..100755 --- a/tests/server/backend-t.in +++ b/tests/server/backend-t diff --git a/tests/server/keytab-t.in b/tests/server/keytab-t index 2a0ceed..2a0ceed 100644..100755 --- a/tests/server/keytab-t.in +++ b/tests/server/keytab-t diff --git a/tests/server/pod-t.in b/tests/server/pod-t index 52d81eb..52d81eb 100644..100755 --- a/tests/server/pod-t.in +++ b/tests/server/pod-t |