aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2007-10-05 01:24:06 +0000
committerRuss Allbery <rra@stanford.edu>2007-10-05 01:24:06 +0000
commitfe56c09a7feeb2d1c9cd699fda07e145c4c354a2 (patch)
treee0e1f0570ef13d801b5a5bcb5920bb2e12180635 /Makefile.am
parentdbe948ca3ebdad97f4f2096f6074623fc2a8e3c8 (diff)
Pull keytab handling in the client into a separate file for later
expansion. Use the fine-grained remctl API instead of the simple one since in some cases we'll be running multiple commands.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e49ba62..600ad83 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,8 +27,8 @@ util_libutil_a_SOURCES = util/concat.c util/messages.c util/util.h \
bin_PROGRAMS = client/wallet
sbin_PROGRAMS = kasetkey/kasetkey
sbin_SCRIPTS = server/keytab-backend server/wallet-backend
-client_wallet_SOURCES = client/file.c client/internal.h client/srvtab.c \
- client/wallet.c system.h
+client_wallet_SOURCES = client/file.c client/internal.h client/keytab.c \
+ client/srvtab.c client/wallet.c system.h
client_wallet_CPPFLAGS = @REMCTL_CPPFLAGS@
client_wallet_LDFLAGS = @REMCTL_LDFLAGS@
client_wallet_LDADD = util/libutil.a portable/libportable.a -lremctl -lkrb5