summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2008-04-24 23:48:19 +0000
committerRuss Allbery <rra@stanford.edu>2008-04-24 23:48:19 +0000
commit54db4deb68be7caedb49b8e949793f770025ce47 (patch)
tree1faba3033164e937297ec7c6c662132c499d1eb9 /Makefile.am
parent4e4fb127f1f54dee7dd28550f9656289e5d026cb (diff)
For builddir != srcdir builds, remove the files we copy over on
make distclean.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 35ccf50..fc11c07 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -139,6 +139,12 @@ clean-local:
[ ! -f perl/Makefile ] || ( set -e; cd perl && $(MAKE) clean )
cd perl && ( [ ! -f Makefile.old ] || mv Makefile.old Makefile )
+# Remove the files that we copy over if and only if builddir != srcdir.
+distclean-local:
+ set -e; if [ x"$(builddir)" != x"$(srcdir)" ] ; then \
+ rm -f $(PERL_FILES) $(TEST_FILES) ; \
+ fi
+
# The bits below are for the test suite, not for the main package.
check_PROGRAMS = tests/runtests tests/portable/asprintf-t \
tests/portable/snprintf-t tests/portable/strlcat-t \