summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2008-04-24 23:22:05 +0000
committerRuss Allbery <rra@stanford.edu>2008-04-24 23:22:05 +0000
commit735106667a911b472ed3c91f80964b6a3c3fd8d2 (patch)
tree6e8398971ff4f730db788aada05f4ff9fd3fa668 /Makefile.am
parent62d7f7e554b992d6c4b8d47818bab16c7ee1a929 (diff)
Include examples/stanford.conf in the distribution. Create another Perl
directory for builddir != srcdir builds.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 68fc70c..222800a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,8 +34,8 @@ EXTRA_DIST = LICENSE autogen client/wallet.pod config/allow-extract \
config/keytab config/keytab.acl config/wallet docs/design \
contrib/README contrib/wallet-report contrib/wallet-report.8 \
docs/design-acl docs/design-api docs/netdb-role-api docs/notes \
- docs/setup kasetkey/README kasetkey/kasetkey.pod $(PERL_FILES) \
- $(TEST_FILES)
+ docs/setup examples/stanford.conf kasetkey/README \
+ kasetkey/kasetkey.pod $(PERL_FILES) $(TEST_FILES)
noinst_LIBRARIES = portable/libportable.a util/libutil.a
portable_libportable_a_SOURCES = portable/dummy.c portable/macros.h \
@@ -117,8 +117,9 @@ all-local: perl/blib/lib/Wallet/Config.pm
perl/blib/lib/Wallet/Config.pm:
set -e; if [ x"$(builddir)" != x"$(srcdir)" ] ; then \
- mkdir perl/Wallet perl/Wallet/ACL perl/Wallet/Object \
- perl/t perl/t/data perl/t/util 2>/dev/null || true ; \
+ mkdir perl/Wallet perl/Wallet/ACL perl/Wallet/ACL/NetDB \
+ perl/Wallet/Object perl/t perl/t/data perl/t/util \
+ 2>/dev/null || true ; \
for f in $(PERL_FILES) ; do \
cp "$(srcdir)/$$f" "$(builddir)/$$f" ; \
done \