aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2010-02-09 23:31:19 -0800
committerRuss Allbery <rra@stanford.edu>2010-02-09 23:31:19 -0800
commitafcc4aba6708d37379ae70bab5ddc38592185e8b (patch)
treefdd6c9a0ab6059d8fc096c75164d746cfbd8bdae /Makefile.am
parent2520a17a1def8d9bae5e6a2e1a63ceff0734bede (diff)
Fix up the distclean and maintainerclean rules
Add .placeholder to the file list, fix the location of the Automake support files that are now in build-aux, and remove an old reference to TEST_FILES.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index d4dc8a5..db6738a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,11 +73,12 @@ warnings:
$(MAKE) V=0 CFLAGS='$(WARNINGS)' $(check_PROGRAMS)
# Remove some additional files.
-DISTCLEANFILES = perl/Makefile
-MAINTAINERCLEANFILES = Makefile.in aclocal.m4 config.h.in config.h.in~ \
- configure client/wallet.1 server/keytab-backend.8 \
- server/wallet-backend.8 tools/compile tools/depcomp tools/install-sh \
- tools/missing
+DISTCLEANFILES = perl/Makefile tests/data/.placeholder
+MAINTAINERCLEANFILES = Makefile.in aclocal.m4 build-aux/compile \
+ build-aux/depcomp build-aux/install-sh build-aux/missing \
+ client/wallet.1 config.h.in config.h.in~ configure \
+ contrib/wallet-report.8 server/keytab-backend.8 \
+ server/wallet-backend.8
# Take appropriate actions in the Perl directory as well. We don't want to
# always build the Perl directory in all-local, since otherwise Automake does
@@ -112,7 +113,7 @@ clean-local:
# Remove the files that we copy over if and only if builddir != srcdir.
distclean-local:
set -e; if [ x"$(builddir)" != x"$(srcdir)" ] ; then \
- rm -f $(PERL_FILES) $(TEST_FILES) ; \
+ rm -f $(PERL_FILES) ; \
fi
# The bits below are for the test suite, not for the main package.