summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2010-02-09 19:43:15 -0800
committerRuss Allbery <rra@stanford.edu>2010-02-09 19:43:15 -0800
commit77d967fb11a4e63967ad1e80929b7096f9d58c05 (patch)
treec2146b703e67f4fae4547666dfecc0f151515636 /Makefile.am
parent31c47c6f5efde6df930b11be281470f75e685324 (diff)
Enable silent rule support and use it for make warnings
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 056229b..77514a7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,8 +70,8 @@ WARNINGS = -g -O -DDEBUG=1 -Wall -W -Wendif-labels -Wpointer-arith \
-Wmissing-prototypes -Wnested-externs -Werror
warnings:
- $(MAKE) CFLAGS='$(WARNINGS)'
- $(MAKE) CFLAGS='$(WARNINGS)' $(check_PROGRAMS)
+ $(MAKE) V=0 CFLAGS='$(WARNINGS)'
+ $(MAKE) V=0 CFLAGS='$(WARNINGS)' $(check_PROGRAMS)
# Remove some additional files.
DISTCLEANFILES = perl/Makefile