summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2007-12-01 05:10:39 +0000
committerRuss Allbery <rra@stanford.edu>2007-12-01 05:10:39 +0000
commit05de6f3525b88331b4165d197da86e2e56c3b065 (patch)
tree4cf6abd28afb0bf62439389d7d1f5bda332ec236 /Makefile.am
parentf3b9604c0d93874a38382f4685c3f7a8ed91bc2f (diff)
Use a slightly hackier way to build things in the Perl directory and
use that for 0.3.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1d2e241..8fb50ea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,8 +79,13 @@ MAINTAINERCLEANFILES = Makefile.in aclocal.m4 config.h.in config.h.in~ \
server/keytab-backend.8 server/wallet-backend.8 tools/compile \
tools/depcomp tools/install-sh tools/missing
-# Take appropriate actions in the Perl directory as well.
-all-local:
+# Take appropriate actions in the Perl directory as well. We don't want to
+# always build the Perl directory in all-local, since otherwise Automake does
+# this for every target, which overrides some hacks we have to do for Debian
+# packaging.
+all-local: perl/blib/lib/Wallet/Config.pm
+
+perl/blib/lib/Wallet/Config.pm:
cd perl && perl Makefile.PL
cd perl && $(MAKE)