summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2007-03-09 00:37:08 +0000
committerRuss Allbery <rra@stanford.edu>2007-03-09 00:37:08 +0000
commita211f36fe96881ca52910216a0bdbd3e2c529af8 (patch)
tree45a983ca71c162fbcae1d7523fb169401ce5281e /Makefile.am
parentdf39a5c8acc53c14df6cba18682090d72c1f94f2 (diff)
Generate the kasetkey man page and install it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6e3de43..2157805 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,12 @@ kasetkey_kasetkey_CPPFLAGS = @AFS_CPPFLAGS@
kasetkey_kasetkey_LDFLAGS = @AFS_LDFLAGS@
kasetkey_kasetkey_LDADD = -lafsauthent -lafsrpc -lpthread -lkrb4
+man_MANS = kasetkey/kasetkey.8
+
+$(srcdir)/kasetkey/kasetkey.8: $(srcdir)/kasetkey/kasetkey.pod
+ pod2man --release=$(VERSION) --center="Administrative Commands" \
+ --section=8 $(srcdir)/kasetkey/kasetkey.pod > $@
+
warnings:
$(MAKE) CFLAGS='$(WARNINGS)'
$(MAKE) CFLAGS='$(WARNINGS)' $(check_PROGRAMS)