summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2007-03-07 08:49:14 +0000
committerRuss Allbery <rra@stanford.edu>2007-03-07 08:49:14 +0000
commitb0e732ad807d10c84ba81ca5afcefc2c0f184f9c (patch)
tree15b763e53fce73701e21ac69f0bb853aaadbc833 /Makefile.am
parent2ea4c462ab9c90be240f7c5e28c2f8c0f4d3a17c (diff)
Redo the coding style of kasetkey and factor out common code.
Authenticate via a srvtab instead of a DES key to make management of the key used by kasetkey easier.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9b3bacd..6e3de43 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,8 +17,7 @@ client_wallet_LDFLAGS = @REMCTL_LDFLAGS@
client_wallet_LDADD = -lremctl
kasetkey_kasetkey_CPPFLAGS = @AFS_CPPFLAGS@
kasetkey_kasetkey_LDFLAGS = @AFS_LDFLAGS@
-kasetkey_kasetkey_LDADD = -lkauth.krb -lprot -lubik -lauth -lrxkad -ldes \
- -lrx -llwp -lcom_err -lafsutil -lsys
+kasetkey_kasetkey_LDADD = -lafsauthent -lafsrpc -lpthread -lkrb4
warnings:
$(MAKE) CFLAGS='$(WARNINGS)'