summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2007-10-05 00:16:26 +0000
committerRuss Allbery <rra@stanford.edu>2007-10-05 00:16:26 +0000
commitdbe948ca3ebdad97f4f2096f6074623fc2a8e3c8 (patch)
treeab0cd9bd84b5402df10da91deefc5354a1b3a73c /Makefile.am
parenta78a2615ae535839700b48d200a097c1c62021be (diff)
Pull the file writing code for the wallet client into a separate file
so that the srvtab and keytab management can share it. Write atomically to a new file and then link and rename to do an atomic update. Leave a backup copy of any file that's replaced.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b433f6d..e49ba62 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,8 +27,8 @@ util_libutil_a_SOURCES = util/concat.c util/messages.c util/util.h \
bin_PROGRAMS = client/wallet
sbin_PROGRAMS = kasetkey/kasetkey
sbin_SCRIPTS = server/keytab-backend server/wallet-backend
-client_wallet_SOURCES = client/internal.h client/srvtab.c client/wallet.c \
- system.h
+client_wallet_SOURCES = client/file.c client/internal.h client/srvtab.c \
+ client/wallet.c system.h
client_wallet_CPPFLAGS = @REMCTL_CPPFLAGS@
client_wallet_LDFLAGS = @REMCTL_LDFLAGS@
client_wallet_LDADD = util/libutil.a portable/libportable.a -lremctl -lkrb5