aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2007-08-29 20:43:26 +0000
committerRuss Allbery <rra@stanford.edu>2007-08-29 20:43:26 +0000
commit146dafddca684e80b474b7e3d5916dac71fb5cf0 (patch)
treed7d2e1df995465afed9543630cc3357a28a93fc2 /Makefile.am
parenta7407ba94a999338d4399d29685f481052b10bb4 (diff)
Add warning flags so that make warnings will actually work. Add the new
Perl files and update the list of files in docs.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 63f4fb4..511e5a7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,9 +6,12 @@
# See README for licensing terms.
AUTOMAKE_OPTIONS = foreign subdir-objects
-EXTRA_DIST = docs/design-acl docs/design-api docs/design-schema \
- docs/netdb-role-api docs/notes kasetkey/kasetkey.pod \
- perl/Wallet/ACL.pm perl/Wallet/ACL/Krb5.pm \
+EXTRA_DIST = TODO docs/design docs/design-acl docs/design-api \
+ docs/netdb-role-api docs/notes docs/setup kasetkey/kasetkey.pod \
+ perl/Wallet/ACL.pm perl/Wallet/ACL/Base.pm perl/Wallet/ACL/Krb5.pm \
+ perl/Wallet/Config.pm perl/Wallet/Object/Base.pm \
+ perl/Wallet/Object/Keytab.pm perl/Wallet/Schema.pm \
+ perl/Wallet/Server.pm perl/t/acl.t perl/t/pod.t \
tests/TESTS tests/client/basic-t.in tests/data/README \
tests/data/cmd-fake tests/data/fake-keytab tests/data/wallet.conf
@@ -28,6 +31,13 @@ $(srcdir)/kasetkey/kasetkey.8: $(srcdir)/kasetkey/kasetkey.pod
pod2man --release=$(VERSION) --center="Administrative Commands" \
--section=8 $(srcdir)/kasetkey/kasetkey.pod > $@
+# A set of flags for warnings. Add -O because gcc won't find some warnings
+# without optimization turned on, and add -DDEBUG=1 so we'll also compile all
+# debugging code and test it.
+WARNINGS = -g -O -DDEBUG=1 -Wall -W -Wendif-labels -Wpointer-arith \
+ -Wbad-function-cast -Wwrite-strings -Wstrict-prototypes \
+ -Wmissing-prototypes -Wnested-externs -Werror
+
warnings:
$(MAKE) CFLAGS='$(WARNINGS)'
$(MAKE) CFLAGS='$(WARNINGS)' $(check_PROGRAMS)