summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2008-02-07 00:46:54 +0000
committerRuss Allbery <rra@stanford.edu>2008-02-07 00:46:54 +0000
commite733132938bc4fc74584b9a7c0f5441eb640e617 (patch)
tree7c2cd522c55d6a2f1e37f75081368529f9d5b8a3 /Makefile.am
parentf9e41d036aebc03adc2a03a956f219fc827e2cdd (diff)
When creating a srvtab based on a just-downloaded keytab, extract the
srvtab key before merging the keytab into an existing file. Otherwise, if the new keys had a lower kvno than the old keys (possible after deleting and recreating the object), the wrong key would be extracted for the srvtab.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ed66448..7e5a5ba 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,7 +26,8 @@ EXTRA_DIST = LICENSE autogen client/wallet.pod config/allow-extract \
tests/data/allow-extract tests/data/cmd-fake tests/data/fake-data \
tests/data/fake-kadmin tests/data/fake-keytab \
tests/data/fake-keytab-2 tests/data/fake-keytab-merge \
- tests/data/fake-srvtab tests/data/wallet.conf tests/libtest.sh
+ tests/data/fake-keytab-old tests/data/fake-srvtab \
+ tests/data/wallet.conf tests/libtest.sh
noinst_LIBRARIES = portable/libportable.a util/libutil.a
portable_libportable_a_SOURCES = portable/dummy.c