summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2013-03-27 14:55:30 -0700
committerRuss Allbery <rra@stanford.edu>2013-03-27 15:18:53 -0700
commit48783ebe55d72e3c32f4d82b77807602a8618da6 (patch)
treeb19bc669391d658d201eed14f6ff9cd12f4d1d36 /Makefile.am
parent21d51c75df0ca974a64b029ee51df16df5bff120 (diff)
Add Perl SQL files to the distribution
Change-Id: Ia131200709531645b47d3bbab065d688e94f211f Reviewed-on: https://gerrit.stanford.edu/982 Reviewed-by: Russ Allbery <rra@stanford.edu> Tested-by: Russ Allbery <rra@stanford.edu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 16 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index a9a0ee3..969ce7a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,7 +29,14 @@ PERL_FILES = perl/Wallet/ACL.pm perl/Wallet/ACL/Base.pm \
perl/Wallet/Schema/Result/Object.pm \
perl/Wallet/Schema/Result/ObjectHistory.pm \
perl/Wallet/Schema/Result/SyncTarget.pm \
- perl/Wallet/Schema/Result/Type.pm perl/t/acl.t perl/t/admin.t \
+ perl/Wallet/Schema/Result/Type.pm \
+ perl/sql/Wallet-Schema-0.07-0.08-MySQL.sql \
+ perl/sql/Wallet-Schema-0.07-0.08-SQLite.sql \
+ perl/sql/Wallet-Schema-0.07-MySQL.sql \
+ perl/sql/Wallet-Schema-0.07-SQLite.sql \
+ perl/sql/Wallet-Schema-0.08-MySQL.sql \
+ perl/sql/Wallet-Schema-0.08-PostgreSQL.sql \
+ perl/sql/Wallet-Schema-0.08-SQLite.sql perl/t/acl.t perl/t/admin.t \
perl/t/config.t perl/t/data/README perl/t/data/keytab-fake \
perl/t/data/keytab.conf perl/t/data/netdb.conf \
perl/t/data/netdb-fake perl/t/file.t perl/t/init.t perl/t/kadmin.t \
@@ -138,14 +145,14 @@ MAINTAINERCLEANFILES = Makefile.in aclocal.m4 build-aux/compile \
all-local: perl/blib/lib/Wallet/Config.pm
perl/blib/lib/Wallet/Config.pm:
- set -e; if [ x"$(builddir)" != x"$(srcdir)" ] ; then \
- mkdir perl/Wallet perl/Wallet/ACL perl/Wallet/ACL/Krb5 \
- perl/Wallet/ACL/NetDB perl/Wallet/Kadmin perl/Wallet/Object \
- perl/Wallet/Schema perl/Wallet/Schema/Result perl/t \
- perl/t/data perl/t/lib 2>/dev/null || true ; \
- for f in $(PERL_FILES) ; do \
- cp "$(srcdir)/$$f" "$(builddir)/$$f" ; \
- done \
+ set -e; if [ x"$(builddir)" != x"$(srcdir)" ] ; then \
+ mkdir perl/Wallet perl/Wallet/ACL perl/Wallet/ACL/Krb5 \
+ perl/Wallet/ACL/NetDB perl/Wallet/Kadmin perl/Wallet/Object \
+ perl/Wallet/Schema perl/Wallet/Schema/Result perl/sql perl/t \
+ perl/t/data perl/t/lib 2>/dev/null || true ; \
+ for f in $(PERL_FILES) ; do \
+ cp "$(srcdir)/$$f" "$(builddir)/$$f" ; \
+ done \
fi
cd perl && perl Makefile.PL
cd perl && $(MAKE)