summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorA. Karl Kornel <akkornel@stanford.edu>2016-01-22 22:19:45 -0800
committerRuss Allbery <eagle@eyrie.org>2016-01-23 15:21:55 -0800
commit61a42ce222ed07da0c22a5394e5f3b59cc4bf690 (patch)
treec7992bb9c566c0d856d388f194b3bf1bfa4e1d8a /Makefile.am
parentd06e318c304a8c55277c616765a8a0502eb9207d (diff)
Make Perl path configurable & check version
Use configure to determine the path to Perl, and error out if Perl is not found or is too old. This also means users can set a path to a custom or weirdly-named Perl binary.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6cabc93..87ba959 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -236,7 +236,7 @@ perl/blib/lib/Wallet/Config.pm: $(srcdir)/perl/lib/Wallet/Config.pm
$(INSTALL_DATA) $(srcdir)/tests/tap/perl/Test/RRA.pm perl/t/lib/Test/
$(INSTALL_DATA) $(srcdir)/tests/tap/perl/Test/RRA/Config.pm \
perl/t/lib/Test/RRA/
- cd perl && perl Build.PL $(WALLET_PERL_FLAGS)
+ cd perl && $(PERL) Build.PL $(WALLET_PERL_FLAGS)
cd perl && ./Build
# This is a really ugly hack to only honor prefix when running make install