aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2010-02-21 17:45:55 -0800
committerRuss Allbery <rra@stanford.edu>2010-02-21 17:45:55 -0800
commit60210334fa3dbd5dd168199063c6ee850d750d0c (patch)
tree31e832ba6788076075d38e20ffd27ebf09430407 /Makefile.am
parente571a8eb96f42de5a114cf11ff1c3d63e5a8d301 (diff)
Imported Upstream version 0.10
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am190
1 files changed, 87 insertions, 103 deletions
diff --git a/Makefile.am b/Makefile.am
index 05f7b8c..d5dccd9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,8 @@
-# Makefile.am -- Automake makefile for wallet.
-# $Id$
+# Automake makefile for wallet.
#
# Written by Russ Allbery <rra@stanford.edu>
-# Copyright 2006, 2007, 2008 Board of Trustees, Leland Stanford Jr. University
+# Copyright 2006, 2007, 2008, 2010
+# Board of Trustees, Leland Stanford Jr. University
#
# See LICENSE for licensing terms.
@@ -10,45 +10,56 @@
# and are not generated or touched by configure. They're listed here to be
# added to EXTRA_DIST and so that they can be copied over properly for
# builddir != srcdir builds.
-PERL_FILES = perl/Wallet/ACL.pm perl/Wallet/ACL/Base.pm \
- perl/Wallet/ACL/Krb5.pm perl/Wallet/ACL/NetDB.pm \
- perl/Wallet/ACL/NetDB/Root.pm perl/Wallet/Admin.pm \
- perl/Wallet/Config.pm perl/Wallet/Database.pm \
- perl/Wallet/Object/Base.pm perl/Wallet/Object/File.pm \
- perl/Wallet/Object/Keytab.pm perl/Wallet/Schema.pm \
- perl/Wallet/Server.pm perl/t/acl.t perl/t/admin.t perl/t/config.t \
- perl/t/data/README perl/t/data/keytab-fake perl/t/data/keytab.conf \
- perl/t/data/netdb.conf perl/t/data/netdb-fake perl/t/init.t \
- perl/t/keytab.t perl/t/lib/Util.pm perl/t/object.t perl/t/pod.t \
- perl/t/schema.t perl/t/server.t perl/t/verifier-netdb.t \
+PERL_FILES = perl/Wallet/ACL.pm perl/Wallet/ACL/Base.pm \
+ perl/Wallet/ACL/Krb5.pm perl/Wallet/ACL/NetDB.pm \
+ perl/Wallet/ACL/NetDB/Root.pm perl/Wallet/Admin.pm \
+ perl/Wallet/Config.pm perl/Wallet/Database.pm perl/Wallet/Kadmin.pm \
+ perl/Wallet/Kadmin/Heimdal.pm perl/Wallet/Kadmin/MIT.pm \
+ perl/Wallet/Object/Base.pm perl/Wallet/Object/File.pm \
+ perl/Wallet/Object/Keytab.pm perl/Wallet/Report.pm \
+ perl/Wallet/Schema.pm perl/Wallet/Server.pm perl/t/acl.t \
+ perl/t/admin.t perl/t/config.t perl/t/data/README \
+ perl/t/data/keytab-fake perl/t/data/keytab.conf \
+ perl/t/data/netdb.conf perl/t/data/netdb-fake perl/t/file.t \
+ perl/t/init.t perl/t/kadmin.t perl/t/keytab.t perl/t/lib/Util.pm \
+ perl/t/object.t perl/t/pod-spelling.t perl/t/pod.t perl/t/report.t \
+ perl/t/schema.t perl/t/server.t perl/t/verifier-netdb.t \
perl/t/verifier.t
-TEST_FILES = tests/TESTS tests/data/README tests/data/allow-extract \
- tests/data/basic.conf tests/data/cmd-fake tests/data/fake-data \
- tests/data/fake-kadmin tests/data/fake-keytab \
- tests/data/fake-keytab-2 tests/data/fake-keytab-merge \
- tests/data/fake-keytab-old tests/data/fake-srvtab \
- tests/data/wallet.conf tests/libtest.sh
AUTOMAKE_OPTIONS = foreign subdir-objects
ACLOCAL_AMFLAGS = -I m4
-EXTRA_DIST = LICENSE autogen client/wallet.pod config/allow-extract \
- config/keytab config/keytab.acl config/wallet docs/design \
- contrib/README contrib/wallet-report contrib/wallet-report.8 \
- docs/design-acl docs/design-api docs/netdb-role-api docs/notes \
- docs/setup examples/stanford.conf kasetkey/README \
- kasetkey/kasetkey.pod $(PERL_FILES) $(TEST_FILES)
+EXTRA_DIST = .gitignore LICENSE autogen client/wallet.pod \
+ config/allow-extract config/keytab config/keytab.acl config/wallet \
+ docs/design contrib/README contrib/convert-srvtab-db \
+ contrib/used-principals contrib/wallet-contacts \
+ contrib/wallet-summary contrib/wallet-summary.8 docs/design-acl \
+ docs/design-api docs/netdb-role-api docs/notes docs/setup \
+ docs/stanford-naming examples/stanford.conf tests/TESTS \
+ tests/data/README tests/data/allow-extract tests/data/basic.conf \
+ tests/data/cmd-fake tests/data/cmd-wrapper tests/data/fake-data \
+ tests/data/fake-kadmin tests/data/fake-keytab \
+ tests/data/fake-keytab-2 tests/data/fake-keytab-merge \
+ tests/data/fake-keytab-old tests/data/fake-srvtab \
+ tests/data/full.conf tests/data/wallet.conf \
+ tests/docs/pod-spelling-t tests/docs/pod-t tests/server/admin-t \
+ tests/server/backend-t tests/server/keytab-t tests/server/report-t \
+ tests/tap/kerberos.sh tests/tap/libtap.sh tests/tap/remctl.sh \
+ tests/util/xmalloc-t $(PERL_FILES)
noinst_LIBRARIES = portable/libportable.a util/libutil.a
-portable_libportable_a_SOURCES = portable/dummy.c portable/macros.h \
- portable/stdbool.h portable/system.h
+portable_libportable_a_SOURCES = portable/dummy.c portable/krb5-extra.c \
+ portable/krb5.h portable/macros.h portable/stdbool.h \
+ portable/system.h portable/uio.h
+portable_libportable_a_CPPFLAGS = $(KRB5_CPPFLAGS)
portable_libportable_a_LIBADD = $(LIBOBJS)
-util_libutil_a_SOURCES = util/concat.c util/messages.c util/messages-krb5.c \
- util/util.h util/xmalloc.c
+util_libutil_a_SOURCES = util/concat.c util/concat.h util/macros.h \
+ util/messages-krb5.c util/messages-krb5.h util/messages.c \
+ util/messages.h util/xmalloc.c util/xmalloc.h
util_libutil_a_CPPFLAGS = $(KRB5_CPPFLAGS)
bin_PROGRAMS = client/wallet
dist_sbin_SCRIPTS = server/keytab-backend server/wallet-admin \
- server/wallet-backend
+ server/wallet-backend server/wallet-report
client_wallet_SOURCES = client/file.c client/internal.h client/keytab.c \
client/krb5.c client/remctl.c client/srvtab.c client/wallet.c
client_wallet_CPPFLAGS = $(REMCTL_CPPFLAGS) $(KRB5_CPPFLAGS)
@@ -57,40 +68,7 @@ client_wallet_LDADD = util/libutil.a portable/libportable.a $(REMCTL_LIBS) \
$(KRB5_LIBS)
dist_man_MANS = client/wallet.1 server/keytab-backend.8 \
- server/wallet-admin.8 server/wallet-backend.8
-
-if AFS
-sbin_PROGRAMS = kasetkey/kasetkey
-kasetkey_kasetkey_CPPFLAGS = $(AFS_CPPFLAGS) $(KRB4_CPPFLAGS)
-kasetkey_kasetkey_LDFLAGS = $(AFS_LDFLAGS) $(KRB4_LDFLAGS)
-kasetkey_kasetkey_LDADD = util/libutil.a portable/libportable.a $(AFS_LIBS) \
- $(KRB4_LIBS)
-dist_man_MANS += kasetkey/kasetkey.8
-endif
-
-$(srcdir)/client/wallet.1: $(srcdir)/client/wallet.pod
- pod2man --release=$(VERSION) --center="Administrative Commands" \
- --section=1 $(srcdir)/client/wallet.pod > $@
-
-$(srcdir)/contrib/wallet-report.8: $(srcdir)/contrib/wallet-report
- pod2man --release=$(VERSION) --center="Administrative Commands" \
- --section=8 $(srcdir)/contrib/wallet-report > $@
-
-$(srcdir)/kasetkey/kasetkey.8: $(srcdir)/kasetkey/kasetkey.pod
- pod2man --release=$(VERSION) --center="Administrative Commands" \
- --section=8 $(srcdir)/kasetkey/kasetkey.pod > $@
-
-$(srcdir)/server/keytab-backend.8: $(srcdir)/server/keytab-backend
- pod2man --release=$(VERSION) --center="Administrative Commands" \
- --section=8 $(srcdir)/server/keytab-backend > $@
-
-$(srcdir)/server/wallet-admin.8: $(srcdir)/server/wallet-admin
- pod2man --release=$(VERSION) --center="Administrative Commands" \
- --section=8 $(srcdir)/server/wallet-admin > $@
-
-$(srcdir)/server/wallet-backend.8: $(srcdir)/server/wallet-backend
- pod2man --release=$(VERSION) --center="Administrative Commands" \
- --section=8 $(srcdir)/server/wallet-backend > $@
+ server/wallet-admin.8 server/wallet-backend.8 server/wallet-report.8
# A set of flags for warnings. Add -O because gcc won't find some warnings
# without optimization turned on, and add -DDEBUG=1 so we'll also compile all
@@ -100,15 +78,16 @@ WARNINGS = -g -O -DDEBUG=1 -Wall -W -Wendif-labels -Wpointer-arith \
-Wmissing-prototypes -Wnested-externs -Werror
warnings:
- $(MAKE) CFLAGS='$(WARNINGS)'
- $(MAKE) CFLAGS='$(WARNINGS)' $(check_PROGRAMS)
+ $(MAKE) V=0 CFLAGS='$(WARNINGS)'
+ $(MAKE) V=0 CFLAGS='$(WARNINGS)' $(check_PROGRAMS)
# Remove some additional files.
-DISTCLEANFILES = perl/Makefile
-MAINTAINERCLEANFILES = Makefile.in aclocal.m4 config.h.in config.h.in~ \
- configure client/wallet.1 kasetkey/kasetkey.8 \
- server/keytab-backend.8 server/wallet-backend.8 tools/compile \
- tools/depcomp tools/install-sh tools/missing
+DISTCLEANFILES = perl/Makefile tests/data/.placeholder
+MAINTAINERCLEANFILES = Makefile.in aclocal.m4 build-aux/compile \
+ build-aux/depcomp build-aux/install-sh build-aux/missing \
+ client/wallet.1 config.h.in config.h.in~ configure \
+ contrib/wallet-report.8 server/keytab-backend.8 \
+ server/wallet-admin.8 server/wallet-backend.8 server/wallet-report.8
# Take appropriate actions in the Perl directory as well. We don't want to
# always build the Perl directory in all-local, since otherwise Automake does
@@ -119,8 +98,8 @@ all-local: perl/blib/lib/Wallet/Config.pm
perl/blib/lib/Wallet/Config.pm:
set -e; if [ x"$(builddir)" != x"$(srcdir)" ] ; then \
mkdir perl/Wallet perl/Wallet/ACL perl/Wallet/ACL/NetDB \
- perl/Wallet/Object perl/t perl/t/data perl/t/lib \
- 2>/dev/null || true ; \
+ perl/Wallet/Kadmin perl/Wallet/Object perl/t perl/t/data \
+ perl/t/lib 2>/dev/null || true ; \
for f in $(PERL_FILES) ; do \
cp "$(srcdir)/$$f" "$(builddir)/$$f" ; \
done \
@@ -143,49 +122,54 @@ clean-local:
# Remove the files that we copy over if and only if builddir != srcdir.
distclean-local:
set -e; if [ x"$(builddir)" != x"$(srcdir)" ] ; then \
- rm -f $(PERL_FILES) $(TEST_FILES) ; \
+ rm -f $(PERL_FILES) ; \
fi
# The bits below are for the test suite, not for the main package.
-check_PROGRAMS = tests/runtests tests/portable/asprintf-t \
- tests/portable/snprintf-t tests/portable/strlcat-t \
- tests/portable/strlcpy-t tests/util/concat-t tests/util/messages-t \
- tests/util/xmalloc
-check_LIBRARIES = tests/libtest.a
-tests_libtest_a_SOURCES = tests/libtest.c tests/libtest.h
+check_PROGRAMS = tests/runtests tests/portable/asprintf-t \
+ tests/portable/mkstemp-t tests/portable/setenv-t \
+ tests/portable/snprintf-t tests/portable/strlcat-t \
+ tests/portable/strlcpy-t tests/util/concat-t \
+ tests/util/messages-krb5-t tests/util/messages-t tests/util/xmalloc
+tests_runtests_CPPFLAGS = -DSOURCE='"$(abs_top_srcdir)/tests"' \
+ -DBUILD='"$(abs_top_builddir)/tests"'
+check_LIBRARIES = tests/tap/libtap.a
+tests_tap_libtap_a_CPPFLAGS = -I$(abs_top_srcdir)/tests $(KRB5_CPPFLAGS)
+tests_tap_libtap_a_SOURCES = tests/tap/basic.c tests/tap/basic.h \
+ tests/tap/kerberos.c tests/tap/kerberos.h tests/tap/messages.c \
+ tests/tap/messages.h tests/tap/process.c tests/tap/process.h
# All of the test programs.
tests_portable_asprintf_t_SOURCES = tests/portable/asprintf-t.c \
- tests/portable/asprintf.c
-tests_portable_asprintf_t_LDADD = tests/libtest.a util/libutil.a \
- portable/libportable.a
+ tests/portable/asprintf.c
+tests_portable_asprintf_t_LDADD = tests/tap/libtap.a portable/libportable.a
+tests_portable_mkstemp_t_SOURCES = tests/portable/mkstemp-t.c \
+ tests/portable/mkstemp.c
+tests_portable_mkstemp_t_LDADD = tests/tap/libtap.a portable/libportable.a
+tests_portable_setenv_t_SOURCES = tests/portable/setenv-t.c \
+ tests/portable/setenv.c
+tests_portable_setenv_t_LDADD = tests/tap/libtap.a portable/libportable.a
tests_portable_snprintf_t_SOURCES = tests/portable/snprintf-t.c \
- tests/portable/snprintf.c
-tests_portable_snprintf_t_LDADD = tests/libtest.a util/libutil.a \
- portable/libportable.a
+ tests/portable/snprintf.c
+tests_portable_snprintf_t_LDADD = tests/tap/libtap.a portable/libportable.a
tests_portable_strlcat_t_SOURCES = tests/portable/strlcat-t.c \
- tests/portable/strlcat.c
-tests_portable_strlcat_t_LDADD = tests/libtest.a util/libutil.a \
- portable/libportable.a
+ tests/portable/strlcat.c
+tests_portable_strlcat_t_LDADD = tests/tap/libtap.a portable/libportable.a
tests_portable_strlcpy_t_SOURCES = tests/portable/strlcpy-t.c \
- tests/portable/strlcpy.c
-tests_portable_strlcpy_t_LDADD = tests/libtest.a util/libutil.a \
+ tests/portable/strlcpy.c
+tests_portable_strlcpy_t_LDADD = tests/tap/libtap.a portable/libportable.a
+tests_util_concat_t_LDADD = tests/tap/libtap.a util/libutil.a \
portable/libportable.a
-tests_util_concat_t_LDADD = tests/libtest.a util/libutil.a \
- portable/libportable.a
-tests_util_messages_t_LDADD = tests/libtest.a util/libutil.a \
+tests_util_messages_krb5_t_CPPFLAGS = $(KRB5_CPPFLAGS)
+tests_util_messages_krb5_t_LDFLAGS = $(KRB5_LDFLAGS)
+tests_util_messages_krb5_t_LDADD = tests/tap/libtap.a util/libutil.a \
+ portable/libportable.a $(KRB5_LIBS)
+tests_util_messages_t_LDADD = tests/tap/libtap.a util/libutil.a \
portable/libportable.a
tests_util_xmalloc_LDADD = util/libutil.a portable/libportable.a
check-local: $(check_PROGRAMS)
- set -e; if [ x"$(builddir)" != x"$(srcdir)" ] ; then \
- mkdir tests/data/acls 2>/dev/null || true ; \
- for f in $(TEST_FILES) ; do \
- cp "$(srcdir)/$$f" "$(builddir)/$$f" ; \
- done \
- fi
- cd tests && ./runtests TESTS
- @echo ''
+ cd tests && ./runtests $(abs_top_srcdir)/tests/TESTS
@echo ''
cd perl && $(MAKE) test