aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRuss Allbery <eagle@eyrie.org>2018-05-27 21:42:35 -0700
committerRuss Allbery <eagle@eyrie.org>2018-05-27 21:42:35 -0700
commit3c5a45223de1e5a1d39afe78c3a323c68050d466 (patch)
tree86a03af17b6023ce12b3ee283e0ea5d396c91b02 /configure.ac
parenteafb48ca60858a6dc480568ff570e8a997ee5113 (diff)
Use rra-c-util RRA_PROG_PERL macro
Rather than rolling this ourselves, use the macro from rra-c-util to probe for the path to Perl and check its version.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 2 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index c912b3c..12b93f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,13 +50,8 @@ AC_ARG_WITH([wallet-port],
[AC_DEFINE_UNQUOTED([WALLET_PORT], [$withval],
[Define to the default server port.])])])
-dnl Determine the path to the Perl binary.
-AC_ARG_VAR([PERL], [Path to the Perl binary])
-AC_PATH_PROG([PERL], [perl])
-AS_IF([test -z "$PERL"],
- [AC_MSG_ERROR([Could not find Perl binary (set PERL to the full path)])])
-AS_IF(["$PERL" -e 'require 5.008'], [:],
- [AC_MSG_ERROR([Perl 5.8 or better is required])])
+dnl Determine the path to the Perl binary and require 5.008 or later.
+RRA_PROG_PERL([5.008])
dnl Probe for required libraries.
RRA_LIB_REMCTL