summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2013-02-27 15:35:32 -0800
committerRuss Allbery <rra@stanford.edu>2013-02-27 16:53:47 -0800
commit4fb142ff9f04d32e18027f3e458226d3ac2f60c3 (patch)
tree949cc95a4bb51438aab9201c0dda224179c45eb9 /configure.ac
parent18edd82ea59d8ddea7647a5848a082b78c68db1f (diff)
Update test configuration documentation
Remove the old tests/data/README documentation and move the note about krb5.conf into tests/config/README. (This should change later to use tests/config for that file.) Add a license statement to that file. Create an empty tests/config directory in the build tree if the build directory is not the source directory. Change-Id: Idf466e32cd114841c45f58dba47b11282467ec8f Reviewed-on: https://gerrit.stanford.edu/848 Reviewed-by: Russ Allbery <rra@stanford.edu> Tested-by: Russ Allbery <rra@stanford.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4fc218b..e417a5e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,4 +70,6 @@ AC_CONFIG_FILES([tests/client/basic-t], [chmod +x tests/client/basic-t])
AC_CONFIG_FILES([tests/client/full-t], [chmod +x tests/client/full-t])
AC_CONFIG_FILES([tests/client/prompt-t], [chmod +x tests/client/prompt-t])
AC_CONFIG_FILES([tests/client/rekey-t], [chmod +x tests/client/rekey-t])
+AC_CONFIG_COMMANDS([tests/config],
+ [test -d tests/config || mkdir tests/config])
AC_OUTPUT