summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2010-02-08 19:41:27 -0800
committerRuss Allbery <rra@stanford.edu>2010-02-08 19:41:27 -0800
commitb093893870d56cd460b16645496ec6c30c62a02f (patch)
tree9867d49c01ce40ce1ae8d34e5077892ee96788db /configure.ac
parent9578292176bef1e1d71cdecd9c2b8d797f6586de (diff)
Initial port to Heimdal
Just get the client code to compile with Heimdal. This will need more work later to use my regular Kerberos portability layer.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bada657..bc55ad0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,10 @@ AC_ARG_WITH([wallet-port],
RRA_LIB_REMCTL
RRA_LIB_KRB5
+RRA_LIB_KRB5_SWITCH
+AC_CHECK_FUNCS([krb5_kt_free_entry])
+AC_CHECK_MEMBERS([krb5_keytab_entry.keyblock], , , [#include <krb5.h>])
+RRA_LIB_KRB5_RESTORE
RRA_LIB_AFS
AS_IF([test x"$rra_afs" = xtrue],
[RRA_LIB_KRB4